SDK Ruby

Descripción

Para que puedas interactuar con Bind ERP desde tu aplicación, esta librería de Ruby incluye todas las clases de los módulos que realizan la comunicación con nuestra API, así como los modelos para crear los objetos requeridos en estos.

Descarga la versión más actualizada del SDK Ruby desde nuestro repositorio en GitHub.

Instalación

  1. Genera una gema:
gem build swagger_client.gemspec
  1. Luego, instala la gema localmente:
gem install ./swagger_client-1.0.0.gem

Para fines de desarrollo, ejecuta el siguiente código para instalar las dependencias necesarias:

gem install --dev ./swagger_client-1.0.0.gem
  1. Finalmente, agrega el siguiente código al archivo Gemfile:
gem 'swagger_client', '~> 1.0.0'

Documentación adicional

Encuentra mayor detalle del proceso de instalación y documentación adicional (en inglés) en nuestro repositorio.